Start a new topic
Solved

This thing sucks

You can't back up your camera roll (not disclosed when sold), you can't use an SD card bigger than 32g,??? Those are the two things I bought this for. This is a glitchy, non-functional, undeveloped hunk of shit. Wow, any photo I take on my phone is uploaded - but I can't delete them? Amazing. The one thing it does is useless and only part way functional. Early adopter tax strikes again. Avoid this device at all costs.

2 people have this problem

 

We understand your frustration, but rest assured that we are standing behind our product. We are a small start-up, and our team is working long hours to update the firmware, the Android App, and the iOS App. We put a lot of effort into this product, and went above and beyond to certify the product on various international certification bodies which is relatively uncommon for a start-up, because we are intend to stay with and support this product in the long term. 


We wanted to get the product into our earliest supporters hands as soon as we can, and unfortunately, there has been more problems than we anticipated. But we are working hard to address all of them to give you the product that we ourselves also want to use. In the meantime, if this is a source of frustration, please take a break from using the product in the next couple of weeks as we iron out these unforeseen kinks. We certainly don't want you to feel like a Beta tester if you did not sign up for that. But rest assured, this product will work as promised. We are making daily improvements in that direction, and we will not stop until the product offers a seamless experience. 


We are also considering implementing exFAT for larger capacity SD cards. 


The Monument Team


I only received my Monument a few days ago, and I have been impressed by the speed that improvements are coming out.  


1) When it arrived, I couldn't do anything with it, because the iOS app was not available yet.  

2) The next time I checked, the iOS app was available!

3) The first time(s) I tried to connect, I had issues, and that was pretty frustrating.

4) I reported the issue to Support.

5) The issue was fixed as a part of the update this morning.


So, while there are some issues right now, and there are lots more features that I would like to see, I am quite impressed with the speed that improvements are coming out.  Keep up the good work team!


2 people like this

Thank you very much for the kind words. It means a lot to us, and we will address all problems as we go as soon as we can. Thank you once again.

Hi all - I just happened to check the App Store last night and saw the app was available, so I jumped in and set it up. Of course I didn't connect it to my TV as instructed, but once I did it worked.


For myself, I am not diving in head first with Monument, and am still backing up my photos to my NAS, as I can await the next few months to shake out bugs and add the new features.


One suggestion I would make is to put the link to the roadmap front and center here in the support site - people will want to be able to find that easily.


mp/m


1 person likes this

Mike, we hear you, and the roadmap is and has been in the Announcements.


1 person likes this
Excellent - thanks! I have been checking it to see if something is live or not before asking for it.

Good luck with the next releases!

mp/m

 

Everything seems to be working so far. Just got it set up. Have it connected to a monitor on HDMI, but only see the Monument screen. How do I get photos to show up there? also don't see in the App where I can manage face naming or tagging? Perhaps it's just me?

The monitor screen will show the pictures as soon as we turn on that feature, which is soon. Face naming is currently possible.

I too was excited and left work early to buy an HDMI lead and 2TB disc...

However it has been sitting all connected up to 3 hours and f* all has happened.

The iPhone just has a spinning icon.

Nothing to see on the monitor.

Flashing blue light on the box

No useful info in the booklet - actually a very poor info booklet. Needs a lot more work to make it user frriendly

Have you been able to set it up? Connect through BT?

No

David, our engineering will contact you.

I'm also sitting with a brick. It keeps asking me to connect a USB drive to get started. I've done this. Does not seem to allow me to do anything else! Quite frustrating.....

Well, I have to say, unlike Scott Walker, I am NOT impressed with the speed of the updates coming out. I, like SO MANY OTHERS, am STUCK, and await support ticket response. It beggars belief that you can send this item out and get SO MANY COMPLAINTS and questions, and that you have to work SO HARD to resolve them. 

Here's an idea: to begin with why not just send out 25 Monuments to random customers with different experience, different systems, different ages etc. See how they get on. When all 25 are saying it works great, then consider sending out some more. That should avoid this nonsense that there were "more problems than we anticipated". Shame on you, do the work BEFORE general release, not after.


1 person likes this