Start a new topic
Solved

Enable Remote Access

Hi!


I just tried to switch on Remote Access, but it fails with the error:


Cannot enable remote access, More info or OK.


What does this function try to do? Does it try to create a port-forward in my firewall? If so, that won't succeed. Is there a manual/topic available on how to enable Remote Access manually?


A little help please... :-(


Regards,


Martijn



We will shortly write a guide on how to do this. 

Same problem. Got an error when I switched it on.

Please find the guide for remote access setup here.

It would be even better if you could select which port you want open rather than you just being on a default

@Scott: Suggest you add this idea to the Feature Requests area for voting. Thanks.

Remote Access is able to be switched on, and in my firewall I see traffic on port 8200 from 52.202.35.206 while switching it on (probably a test from your systems to see if traffic is routed correctly), but when I try to access Monument remotely, the app is not able to connect and there is no traffic visible in my firewall. It almost seems like the app tries to connect to a different IP-adres, but I'm unable to verify that.

Any ideas?

 

Regards,


Martijn


@Martijn: we have seen this issue as well until we went through the manual port opening ritual, as it appears to be needed with some routers. See Enable Remote Access.

Hi! I think I didn't mention I already opened the port in my router/firewall. If that is what you mean. I can see the traffic in the logging of my firewall, but only the traffic generated by the setup, not after it is enabled. I tried it from multiple external connections, on wifi and 3G/4G. Hope you have more ideas where to look. With kind regards, Martijn

@Martijn: If you opened the port and the Monument has a static address, we are short out of options other that having suspicions mainly focused on the router. On the Monument side, there is one unlikely possibility, and it is easy to diagnose as you would not be able to access the Monument even within your own home network. On rare occasions, Monument may stop responding until it is restarted. Apart from that, router is the culprit in general. The open port 8200 (TCP) is indeed forwarding to a static Monument address as port 8200 (TCP). Right?

Yes, right. The monument has en static IP-address and port 8200 is forwarded. The fact that the Remote Access setup finishes correctly and  I see the traffic in the router, confirms that the setup is correct. I forward a number of ports to internal devices and they all work as expected.


On the internal network I can access Monument without any issues. The only difference from the setup you described, is that my Monument is connected with a cable in stead of wireless, but that shouln;t make a difference I suppose.


I'll do a reset tonight and post the outcome here.


The only difference from the setup you described, is that my Monument is connected with a cable in stead of wireless


Ok, this is a clue. If the static address belongs to the wireless side, and the ethernet port is connected with another IP address, we can have unexpected behavior as ethernet port is prioritized over wireless, Your Monument may be expecting the connection on the wrong port. Just to keep things simple, stick with wireless (network access, static address, etc.) with the port forwarding connecting to wireless. Not entirely sure that this is the issue, but a likely culprit.

 I switched to wifi, but the behaviour is exactly the same. Works normally when phone is connected to local wifi, but not able to connect to Monument when on 4G.


Router looks exactly the same, logging shows traffic when enabling Remote Access, nothing after that.


I did notice something weird when configuring the new DHCP-reservation. The MAC-address of Monument shows as 057b8b6c00030001442c057b8b6c. Not really a valid MAC address to my opinion. My DHCP server, running on Windows, does not assign an IP-address to Monument when I use this MAC address, now using it without reservation, but this should not influence the use of Remote Access.


Also a reboot did not solve the issue.


Looking forward to your answer.


Kind regards,


Martijn

@Martijn: There is a extremely minor possibility that the MAC address did not get burned into the unit during production. We have not seen any units this way, but it is a possibility. Our Engineering can screen share with you to look at whether this is the case. We'll inform them, and they will get into touch with you. Thank you for your patience.

Ok, that would be great.